summaryrefslogtreecommitdiffstats
path: root/third_party/rust/failure_derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/failure_derive/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/third_party/rust/failure_derive/Cargo.toml b/third_party/rust/failure_derive/Cargo.toml
new file mode 100644
index 0000000000..ec45dc0b1d
--- /dev/null
+++ b/third_party/rust/failure_derive/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+authors = ["Without Boats <woboats@gmail.com>"]
+description = "derives for the failure crate"
+license = "MIT OR Apache-2.0"
+name = "failure_derive"
+repository = "https://github.com/withoutboats/failure_derive"
+homepage = "https://rust-lang-nursery.github.io/failure/"
+documentation = "https://docs.rs/failure"
+version = "0.1.6"
+build = "build.rs"
+
+[dependencies]
+quote = "1"
+syn = "1.0.3"
+synstructure = "0.12.0"
+proc-macro2 = "1"
+
+[dev-dependencies.failure]
+version = "0.1.0"
+path = ".."
+
+[lib]
+proc-macro = true
+
+[features]
+# This is kept for backward-compatibility reasons, but is otherwise a no-op
+std = []