summaryrefslogtreecommitdiffstats
path: root/third_party/rust/futures-0.1.29/appveyor.yml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/futures-0.1.29/appveyor.yml')
-rw-r--r--third_party/rust/futures-0.1.29/appveyor.yml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/futures-0.1.29/appveyor.yml b/third_party/rust/futures-0.1.29/appveyor.yml
new file mode 100644
index 0000000000..b516f6084c
--- /dev/null
+++ b/third_party/rust/futures-0.1.29/appveyor.yml
@@ -0,0 +1,39 @@
+environment:
+
+ # At the time this was added AppVeyor was having troubles with checking
+ # revocation of SSL certificates of sites like static.rust-lang.org and what
+ # we think is crates.io. The libcurl HTTP client by default checks for
+ # revocation on Windows and according to a mailing list [1] this can be
+ # disabled.
+ #
+ # The `CARGO_HTTP_CHECK_REVOKE` env var here tells cargo to disable SSL
+ # revocation checking on Windows in libcurl. Note, though, that rustup, which
+ # we're using to download Rust here, also uses libcurl as the default backend.
+ # Unlike Cargo, however, rustup doesn't have a mechanism to disable revocation
+ # checking. To get rustup working we set `RUSTUP_USE_HYPER` which forces it to
+ # use the Hyper instead of libcurl backend. Both Hyper and libcurl use
+ # schannel on Windows but it appears that Hyper configures it slightly
+ # differently such that revocation checking isn't turned on by default.
+ #
+ # [1]: https://curl.haxx.se/mail/lib-2016-03/0202.html
+ RUSTUP_USE_HYPER: 1
+ CARGO_HTTP_CHECK_REVOKE: false
+
+ matrix:
+ - TARGET: x86_64-pc-windows-msvc
+install:
+ - set PATH=C:\Program Files\Git\mingw64\bin;%PATH%
+ - curl -sSf -o rustup-init.exe https://win.rustup.rs/
+ - rustup-init.exe -y --default-host %TARGET%
+ - set PATH=%PATH%;C:\Users\appveyor\.cargo\bin
+ - rustc -V
+ - cargo -V
+
+build: false
+
+test_script:
+ - cargo build
+ - cargo build --no-default-features
+ - cargo test
+ - cargo test --no-default-features --features use_std
+ - cargo test --manifest-path futures-cpupool/Cargo.toml