summaryrefslogtreecommitdiffstats
path: root/third_party/rust/hawk/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/hawk/Cargo.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/third_party/rust/hawk/Cargo.toml b/third_party/rust/hawk/Cargo.toml
new file mode 100644
index 0000000000..cffced663f
--- /dev/null
+++ b/third_party/rust/hawk/Cargo.toml
@@ -0,0 +1,57 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "hawk"
+version = "3.2.1"
+authors = ["Jonas Finnemann Jensen <jopsen@gmail.com>", "Dustin J. Mitchell <dustin@mozilla.com>"]
+build = "build.rs"
+exclude = ["docker/*", ".taskcluster.yml", ".git*"]
+description = "Hawk Implementation for Rust"
+homepage = "https://docs.rs/hawk/"
+documentation = "https://docs.rs/hawk/"
+readme = "README.md"
+license = "MPL-2.0"
+repository = "https://github.com/taskcluster/rust-hawk"
+[dependencies.anyhow]
+version = "1.0"
+
+[dependencies.base64]
+version = "0.12"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.once_cell]
+version = "1.4"
+
+[dependencies.openssl]
+version = "0.10.20"
+optional = true
+
+[dependencies.ring]
+version = "0.16.0"
+optional = true
+
+[dependencies.thiserror]
+version = "1.0"
+
+[dependencies.url]
+version = "2.1"
+[dev-dependencies.pretty_assertions]
+version = "^0.6.1"
+
+[features]
+default = ["use_ring"]
+use_openssl = ["openssl"]
+use_ring = ["ring"]