summaryrefslogtreecommitdiffstats
path: root/third_party/rust/hyper/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/hyper/Cargo.toml')
-rw-r--r--third_party/rust/hyper/Cargo.toml247
1 files changed, 247 insertions, 0 deletions
diff --git a/third_party/rust/hyper/Cargo.toml b/third_party/rust/hyper/Cargo.toml
new file mode 100644
index 0000000000..e29b3fea95
--- /dev/null
+++ b/third_party/rust/hyper/Cargo.toml
@@ -0,0 +1,247 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "hyper"
+version = "0.13.5"
+authors = ["Sean McArthur <sean@seanmonstar.com>"]
+include = ["Cargo.toml", "LICENSE", "src/**/*"]
+description = "A fast and correct HTTP library."
+homepage = "https://hyper.rs"
+documentation = "https://docs.rs/hyper"
+readme = "README.md"
+keywords = ["http", "hyper", "hyperium"]
+categories = ["network-programming", "web-programming::http-client", "web-programming::http-server"]
+license = "MIT"
+repository = "https://github.com/hyperium/hyper"
+[package.metadata.docs.rs]
+features = ["runtime", "stream"]
+[profile.bench]
+codegen-units = 1
+incremental = false
+
+[profile.release]
+codegen-units = 1
+incremental = false
+
+[[example]]
+name = "client"
+path = "examples/client.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "client_json"
+path = "examples/client_json.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "echo"
+path = "examples/echo.rs"
+required-features = ["runtime", "stream"]
+
+[[example]]
+name = "gateway"
+path = "examples/gateway.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "hello"
+path = "examples/hello.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "http_proxy"
+path = "examples/http_proxy.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "multi_server"
+path = "examples/multi_server.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "params"
+path = "examples/params.rs"
+required-features = ["runtime", "stream"]
+
+[[example]]
+name = "send_file"
+path = "examples/send_file.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "single_threaded"
+path = "examples/single_threaded.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "state"
+path = "examples/state.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "tower_client"
+path = "examples/tower_client.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "tower_server"
+path = "examples/tower_server.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "upgrades"
+path = "examples/upgrades.rs"
+required-features = ["runtime"]
+
+[[example]]
+name = "web_api"
+path = "examples/web_api.rs"
+required-features = ["runtime", "stream"]
+
+[[test]]
+name = "client"
+path = "tests/client.rs"
+required-features = ["runtime", "stream"]
+
+[[test]]
+name = "integration"
+path = "tests/integration.rs"
+required-features = ["runtime", "stream"]
+
+[[test]]
+name = "server"
+path = "tests/server.rs"
+required-features = ["runtime"]
+
+[[bench]]
+name = "body"
+path = "benches/body.rs"
+required-features = ["runtime", "stream"]
+
+[[bench]]
+name = "connect"
+path = "benches/connect.rs"
+required-features = ["runtime"]
+
+[[bench]]
+name = "end_to_end"
+path = "benches/end_to_end.rs"
+required-features = ["runtime"]
+
+[[bench]]
+name = "pipeline"
+path = "benches/pipeline.rs"
+required-features = ["runtime"]
+
+[[bench]]
+name = "server"
+path = "benches/server.rs"
+required-features = ["runtime", "stream"]
+[dependencies.bytes]
+version = "0.5"
+
+[dependencies.futures-channel]
+version = "0.3"
+
+[dependencies.futures-core]
+version = "0.3"
+default-features = false
+
+[dependencies.futures-util]
+version = "0.3"
+default-features = false
+
+[dependencies.h2]
+version = "0.2.2"
+
+[dependencies.http]
+version = "0.2"
+
+[dependencies.http-body]
+version = "0.3.1"
+
+[dependencies.httparse]
+version = "1.0"
+
+[dependencies.itoa]
+version = "0.4.1"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.net2]
+version = "0.2.32"
+optional = true
+
+[dependencies.pin-project]
+version = "0.4"
+
+[dependencies.time]
+version = "0.1"
+
+[dependencies.tokio]
+version = "0.2"
+features = ["sync"]
+
+[dependencies.tower-service]
+version = "0.3"
+
+[dependencies.want]
+version = "0.3"
+[dev-dependencies.futures-util]
+version = "0.3"
+features = ["alloc"]
+default-features = false
+
+[dev-dependencies.matches]
+version = "0.1"
+
+[dev-dependencies.num_cpus]
+version = "1.0"
+
+[dev-dependencies.pretty_env_logger]
+version = "0.4"
+
+[dev-dependencies.serde]
+version = "1.0"
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.spmc]
+version = "0.3"
+
+[dev-dependencies.tokio]
+version = "0.2.2"
+features = ["fs", "macros", "io-std", "rt-util", "sync", "time", "test-util"]
+
+[dev-dependencies.tokio-test]
+version = "0.2"
+
+[dev-dependencies.tower-util]
+version = "0.3"
+
+[dev-dependencies.url]
+version = "1.0"
+
+[features]
+__internal_happy_eyeballs_tests = []
+default = ["runtime", "stream"]
+nightly = []
+runtime = ["tcp", "tokio/rt-core"]
+stream = []
+tcp = ["net2", "tokio/blocking", "tokio/tcp", "tokio/time"]