summaryrefslogtreecommitdiffstats
path: root/third_party/rust/image/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/image/Cargo.toml')
-rw-r--r--third_party/rust/image/Cargo.toml90
1 files changed, 90 insertions, 0 deletions
diff --git a/third_party/rust/image/Cargo.toml b/third_party/rust/image/Cargo.toml
new file mode 100644
index 0000000000..e774254d1e
--- /dev/null
+++ b/third_party/rust/image/Cargo.toml
@@ -0,0 +1,90 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "image"
+version = "0.23.0"
+authors = ["The image-rs Developers"]
+exclude = ["src/png/testdata/*", "examples/*", "tests/*"]
+description = "Imaging library written in Rust. Provides basic filters and decoders for the most common image formats."
+homepage = "https://github.com/image-rs/image"
+documentation = "https://docs.rs/image"
+readme = "README.md"
+categories = ["multimedia::images", "multimedia::encoding"]
+license = "MIT"
+repository = "https://github.com/image-rs/image"
+
+[lib]
+name = "image"
+path = "./src/lib.rs"
+[dependencies.bytemuck]
+version = "1"
+
+[dependencies.byteorder]
+version = "1.3.2"
+
+[dependencies.gif]
+version = "0.10.0"
+optional = true
+
+[dependencies.jpeg]
+version = "0.1"
+optional = true
+default-features = false
+package = "jpeg-decoder"
+
+[dependencies.num-iter]
+version = "0.1.32"
+
+[dependencies.num-rational]
+version = "0.2.1"
+default-features = false
+
+[dependencies.num-traits]
+version = "0.2.0"
+
+[dependencies.png]
+version = "0.15.2"
+optional = true
+
+[dependencies.scoped_threadpool]
+version = "0.1"
+optional = true
+
+[dependencies.tiff]
+version = "0.4.0"
+optional = true
+[dev-dependencies.crc32fast]
+version = "1.2.0"
+
+[dev-dependencies.glob]
+version = "0.3"
+
+[dev-dependencies.num-complex]
+version = "0.2.0"
+
+[dev-dependencies.quickcheck]
+version = "0.9"
+
+[features]
+benchmarks = []
+bmp = []
+dds = ["dxt"]
+default = ["gif", "jpeg", "ico", "png", "pnm", "tga", "tiff", "webp", "bmp", "hdr", "dxt", "dds", "jpeg_rayon"]
+dxt = []
+hdr = ["scoped_threadpool"]
+ico = ["bmp", "png"]
+jpeg_rayon = ["jpeg/rayon"]
+pnm = []
+tga = []
+webp = []