summaryrefslogtreecommitdiffstats
path: root/third_party/rust/lucet-runtime-wasmsbx/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/lucet-runtime-wasmsbx/Cargo.toml')
-rw-r--r--third_party/rust/lucet-runtime-wasmsbx/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/lucet-runtime-wasmsbx/Cargo.toml b/third_party/rust/lucet-runtime-wasmsbx/Cargo.toml
new file mode 100644
index 0000000000..4c114da7d6
--- /dev/null
+++ b/third_party/rust/lucet-runtime-wasmsbx/Cargo.toml
@@ -0,0 +1,51 @@
+[package]
+name = "lucet-runtime-wasmsbx"
+version = "0.1.1"
+description = "Pure Rust runtime for Lucet WebAssembly toolchain"
+homepage = "https://github.com/fastly/lucet"
+repository = "https://github.com/fastly/lucet"
+license = "Apache-2.0 WITH LLVM-exception"
+categories = ["wasm"]
+authors = ["Lucet team <lucet@fastly.com>"]
+edition = "2018"
+
+[dependencies]
+libc = "0.2.65"
+lucet-runtime-internals = { path = "lucet-runtime-internals", version = "0.1.1", package = "lucet-runtime-internals-wasmsbx" }
+lucet-module = { path = "../lucet-module", version = "0.1.1", package="lucet-module-wasmsbx" }
+num-traits = "0.2"
+num-derive = "0.3"
+
+[dev-dependencies]
+byteorder = "1.2"
+failure = "0.1"
+lazy_static = "1.1"
+lucetc = { path = "../lucetc" }
+lucet-runtime-tests = { path = "lucet-runtime-tests", version = "0.1.1" }
+lucet-wasi-sdk = { path = "../lucet-wasi-sdk" }
+nix = "0.13"
+rayon = "1.0"
+tempfile = "3.0"
+
+[build-dependencies]
+# only used for tests
+cc = "1.0"
+
+[features]
+signature_checking = ["lucet-module/signature_checking"]
+
+[lib]
+name = "lucet_runtime"
+crate-type = ["rlib", "staticlib"]
+
+[package.metadata.deb]
+name = "fst-lucet-runtime"
+maintainer = "Adam C. Foltzer <acfoltzer@fastly.com>"
+depends = "$auto"
+priority = "optional"
+assets = [
+ ["target/release/liblucet_runtime.a", "/opt/fst-lucet-runtime/lib/", "644"],
+ ["target/release/liblucet_runtime.rlib", "/opt/fst-lucet-runtime/lib/", "644"],
+ ["target/release/liblucet_runtime.so", "/opt/fst-lucet-runtime/lib/", "755"],
+ ["include/*.h", "/opt/fst-lucet-runtime/include/", "644"],
+]