summaryrefslogtreecommitdiffstats
path: root/third_party/rust/lucet-wasi-wasmsbx/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/lucet-wasi-wasmsbx/Cargo.toml')
-rw-r--r--third_party/rust/lucet-wasi-wasmsbx/Cargo.toml67
1 files changed, 67 insertions, 0 deletions
diff --git a/third_party/rust/lucet-wasi-wasmsbx/Cargo.toml b/third_party/rust/lucet-wasi-wasmsbx/Cargo.toml
new file mode 100644
index 0000000000..54d41f6e49
--- /dev/null
+++ b/third_party/rust/lucet-wasi-wasmsbx/Cargo.toml
@@ -0,0 +1,67 @@
+[package]
+name = "lucet-wasi-wasmsbx"
+version = "0.1.1"
+description = "Fastly's runtime for the WebAssembly System Interface (WASI)"
+homepage = "https://github.com/fastly/lucet"
+repository = "https://github.com/fastly/lucet"
+license = "Apache-2.0 WITH LLVM-exception"
+categories = ["wasm"]
+authors = ["Lucet team <lucet@fastly.com>"]
+edition = "2018"
+
+# `src/wasi_host.rs` is automatically generated using clang and
+# wasi-libc headers. This requires these to be present, and installed
+# at specific paths, which is not something we can rely on outside
+# of our environment.
+# So, we follow what most other tools using `bindgen` do, and provide
+# a pre-generated version of the file, along with a way to update it.
+# This is what the `update-bindings` feature do. It requires the WASI SDK
+# to be either installed in `/opt/wasi-sdk`, or at a location defined by
+# a `WASI_SDK` environment variable, as well as `clang` headers either
+# being part of `WASI_SDK`, or found in a path defined by a
+# `CLANG_ROOT` environment variable.
+[features]
+update-bindings = ["bindgen"]
+
+[dependencies]
+cast = "0.2"
+failure = "0.1"
+libc = "0.2.65"
+lucet-runtime = { path = "../lucet-runtime", version = "0.1.1", package = "lucet-runtime-wasmsbx" }
+lucet-runtime-internals = { path = "../lucet-runtime/lucet-runtime-internals", version = "0.1.1", package = "lucet-runtime-internals-wasmsbx" }
+lucet-module = { path = "../lucet-module", version = "0.1.1", package="lucet-module-wasmsbx" }
+nix = "0.13"
+rand = "0.7"
+lazy_static = ">=1.4.0"
+
+[target.'cfg(target_os = "macos")'.dependencies]
+mach = "0.3.2"
+
+[dev-dependencies]
+lucet-wasi-sdk = { path = "../lucet-wasi-sdk", version = "0.1.1" }
+lucetc = { path = "../lucetc", version = "0.1.1" }
+tempfile = "3.0"
+
+[build-dependencies.bindgen]
+version = "0.47"
+optional = true
+
+[lib]
+name = "lucet_wasi"
+crate-type = ["rlib", "staticlib"]
+
+[package.metadata.deb]
+name = "fst-lucet-wasi"
+maintainer = "Adam C. Foltzer <acfoltzer@fastly.com>"
+depends = "$auto"
+priority = "optional"
+assets = [
+ ["target/release/liblucet_wasi.a", "/opt/fst-lucet-wasi/lib/", "644"],
+ ["target/release/liblucet_wasi.rlib", "/opt/fst-lucet-wasi/lib/", "644"],
+ ["target/release/liblucet_wasi.so", "/opt/fst-lucet-wasi/lib/", "755"],
+ ["include/*.h", "/opt/fst-lucet-wasi/include/", "644"],
+ ["LICENSE", "/opt/fst-lucet-wasi/share/doc/lucet-wasi/", "644"],
+ ["LICENSE.wasmtime", "/opt/fst-lucet-wasi/share/doc/lucet-wasi/", "644"],
+ ["LICENSE.cloudabi-utils", "/opt/fst-lucet-wasi/share/doc/lucet-wasi/", "644"],
+ ["bindings.json", "/opt/fst-lucet-wasi/share/", "644"],
+]