summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ordered-float/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ordered-float/Cargo.toml')
-rw-r--r--third_party/rust/ordered-float/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/third_party/rust/ordered-float/Cargo.toml b/third_party/rust/ordered-float/Cargo.toml
new file mode 100644
index 0000000000..980a78894c
--- /dev/null
+++ b/third_party/rust/ordered-float/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "ordered-float"
+version = "1.0.1"
+authors = ["Jonathan Reem <jonathan.reem@gmail.com>", "Matt Brubeck <mbrubeck@limpet.net>"]
+description = "Wrappers for total ordering on floats"
+readme = "README.md"
+keywords = ["no_std", "ord", "f64", "f32", "sort"]
+categories = ["science", "rust-patterns", "no-std"]
+license = "MIT"
+repository = "https://github.com/reem/rust-ordered-float"
+[dependencies.num-traits]
+version = "0.2"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[features]
+default = ["std"]
+std = []