summaryrefslogtreecommitdiffstats
path: root/third_party/rust/packed_simd/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/packed_simd/Cargo.toml')
-rw-r--r--third_party/rust/packed_simd/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/packed_simd/Cargo.toml b/third_party/rust/packed_simd/Cargo.toml
new file mode 100644
index 0000000000..70bbf26ed2
--- /dev/null
+++ b/third_party/rust/packed_simd/Cargo.toml
@@ -0,0 +1,42 @@
+[package]
+name = "packed_simd"
+version = "0.3.4"
+authors = ["Gonzalo Brito Gadeschi <gonzalobg88@gmail.com>"]
+description = "Portable Packed SIMD vectors"
+documentation = "https://docs.rs/crate/packed_simd/"
+homepage = "https://github.com/rust-lang-nursery/packed_simd"
+repository = "https://github.com/rust-lang-nursery/packed_simd"
+keywords = ["simd", "vector", "portability"]
+categories = ["hardware-support", "concurrency", "no-std", "data-structures"]
+license = "MIT/Apache-2.0"
+build = "build.rs"
+edition = "2018"
+
+[badges]
+appveyor = { repository = "rust-lang-nursery/packed_simd" }
+travis-ci = { repository = "rust-lang-nursery/packed_simd" }
+codecov = { repository = "rust-lang-nursery/packed_simd" }
+is-it-maintained-issue-resolution = { repository = "rust-lang-nursery/packed_simd" }
+is-it-maintained-open-issues = { repository = "rust-lang-nursery/packed_simd" }
+maintenance = { status = "experimental" }
+
+[dependencies]
+cfg-if = "0.1.10"
+core_arch = { version = "0.1.5", optional = true }
+
+[features]
+default = []
+into_bits = []
+libcore_neon = []
+
+[dev-dependencies]
+paste = "^0.1.3"
+arrayvec = { version = "^0.5", default-features = false }
+
+[target.'cfg(target_arch = "x86_64")'.dependencies.sleef-sys]
+version = "0.1.2"
+optional = true
+
+[target.wasm32-unknown-unknown.dev-dependencies]
+wasm-bindgen = "=0.2.52"
+wasm-bindgen-test = "=0.3.2"