summaryrefslogtreecommitdiffstats
path: root/third_party/rust/pkcs11/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/pkcs11/Cargo.toml')
-rw-r--r--third_party/rust/pkcs11/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/pkcs11/Cargo.toml b/third_party/rust/pkcs11/Cargo.toml
new file mode 100644
index 0000000000..7dbaf28199
--- /dev/null
+++ b/third_party/rust/pkcs11/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "pkcs11"
+version = "0.4.1"
+authors = ["Marcus Heese <marcus.heese@gmail.com>"]
+exclude = ["pkcs11-docs/**"]
+description = "Rust PKCS#11 Library"
+homepage = "https://github.com/mheese/rust-pkcs11"
+keywords = ["pkcs11", "cryptoki"]
+categories = ["external-ffi-bindings", "cryptography", "hardware-support"]
+license = "Apache-2.0"
+repository = "https://github.com/mheese/rust-pkcs11"
+[dependencies.libloading]
+version = "^0.5"
+
+[dependencies.num-bigint]
+version = "^0.2"
+[dev-dependencies.hex]
+version = "^0.3"
+
+[dev-dependencies.num-traits]
+version = "^0.1"
+
+[dev-dependencies.serial_test]
+version = "~0.1"
+
+[dev-dependencies.serial_test_derive]
+version = "~0.1"