summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rental/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/rental/Cargo.toml')
-rw-r--r--third_party/rust/rental/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/rental/Cargo.toml b/third_party/rust/rental/Cargo.toml
new file mode 100644
index 0000000000..2634b4881d
--- /dev/null
+++ b/third_party/rust/rental/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "rental"
+version = "0.5.5"
+authors = ["Jameson Ernst <jameson@jpernst.com>"]
+description = "A macro to generate safe self-referential structs, plus premade types for common use cases."
+documentation = "https://docs.rs/rental"
+readme = "README.md"
+keywords = ["lifetime", "ownership", "borrowing", "self", "reference"]
+categories = ["rust-patterns", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jpernst/rental"
+[dependencies.rental-impl]
+version = "=0.5.5"
+
+[dependencies.stable_deref_trait]
+version = "1.0.0"
+default-features = false
+
+[features]
+default = ["std"]
+std = ["stable_deref_trait/std"]