summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ron/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ron/Cargo.toml')
-rw-r--r--third_party/rust/ron/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/third_party/rust/ron/Cargo.toml b/third_party/rust/ron/Cargo.toml
new file mode 100644
index 0000000000..a5092d0c54
--- /dev/null
+++ b/third_party/rust/ron/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "ron"
+version = "0.6.2"
+authors = ["Christopher Durham <cad97@cad97.com>", "Dzmitry Malyshau <kvarkus@gmail.com>", "Thomas Schaller <torkleyy@gmail.com>"]
+exclude = ["bors.toml", ".travis.yml"]
+description = "Rusty Object Notation"
+homepage = "https://github.com/ron-rs/ron"
+documentation = "https://docs.rs/ron/"
+readme = "README.md"
+keywords = ["parser", "serde", "serialization"]
+categories = ["encoding"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/ron-rs/ron"
+
+[lib]
+name = "ron"
+[dependencies.base64]
+version = "0.12"
+
+[dependencies.bitflags]
+version = "1.0.4"
+
+[dependencies.indexmap]
+version = "1.0.2"
+features = ["serde-1"]
+optional = true
+
+[dependencies.serde]
+version = "1.0.60"
+features = ["serde_derive"]
+[dev-dependencies.serde_bytes]
+version = "0.11"
+
+[dev-dependencies.serde_json]
+version = "1"