summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde_with/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/serde_with/Cargo.toml73
1 files changed, 73 insertions, 0 deletions
diff --git a/third_party/rust/serde_with/Cargo.toml b/third_party/rust/serde_with/Cargo.toml
new file mode 100644
index 0000000000..26a7ce2a6b
--- /dev/null
+++ b/third_party/rust/serde_with/Cargo.toml
@@ -0,0 +1,73 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "serde_with"
+version = "1.4.0"
+authors = ["jonasbb"]
+exclude = [".codecov.yml", ".gitignore", ".pre-commit-config.yaml", ".travis.yml", "bors.toml", "README.tpl", "rustfmt.toml"]
+description = "Custom de/serialization functions for Rust's serde"
+documentation = "https://docs.rs/serde_with/"
+readme = "README.md"
+keywords = ["serde", "utilities", "serialization", "deserialization"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/jonasbb/serde_with"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.chrono]
+version = "0.4.1"
+features = ["serde"]
+optional = true
+
+[dependencies.serde]
+version = "1.0.75"
+
+[dependencies.serde_json]
+version = "1.0.1"
+optional = true
+
+[dependencies.serde_with_macros]
+version = "1.1.0"
+optional = true
+[dev-dependencies.fnv]
+version = "1.0.6"
+
+[dev-dependencies.pretty_assertions]
+version = "0.6.1"
+
+[dev-dependencies.ron]
+version = ">=0.3.0, <0.6"
+
+[dev-dependencies.serde_derive]
+version = "1.0.75"
+
+[dev-dependencies.serde_json]
+version = "1.0.25"
+
+[dev-dependencies.version-sync]
+version = "0.8.1"
+
+[features]
+default = ["macros"]
+json = ["serde_json"]
+macros = ["serde_with_macros"]
+[badges.codecov]
+branch = "master"
+repository = "jonasbb/serde_with"
+service = "github"
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+branch = "master"
+repository = "jonasbb/serde_with"