summaryrefslogtreecommitdiffstats
path: root/third_party/rust/spirv-cross-internal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/spirv-cross-internal/Cargo.toml')
-rw-r--r--third_party/rust/spirv-cross-internal/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/rust/spirv-cross-internal/Cargo.toml b/third_party/rust/spirv-cross-internal/Cargo.toml
new file mode 100644
index 0000000000..2937c4ce8c
--- /dev/null
+++ b/third_party/rust/spirv-cross-internal/Cargo.toml
@@ -0,0 +1,22 @@
+# the name has to not be a prefix to any modules!
+[package]
+name = "spirv-cross-internal"
+version = "0.1.0"
+authors = ["Joshua Groves <josh@joshgroves.com>"]
+description = "Safe wrapper around SPIRV-Cross"
+license = "MIT/Apache-2.0"
+homepage = "https://github.com/grovesNL/spirv_cross"
+repository = "https://github.com/grovesNL/spirv_cross"
+readme = "../README.md"
+keywords = ["spirv", "cross"]
+build = "build.rs"
+edition = "2018"
+
+[features]
+default = []
+glsl = []
+hlsl = []
+msl = []
+
+[target.'cfg(not(target_arch = "wasm32"))'.build-dependencies]
+cc = { version = "1", features = ["parallel"] }