summaryrefslogtreecommitdiffstats
path: root/third_party/rust/termion/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/termion/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/rust/termion/Cargo.toml b/third_party/rust/termion/Cargo.toml
new file mode 100644
index 0000000000..a4415719a8
--- /dev/null
+++ b/third_party/rust/termion/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "termion"
+version = "1.5.1"
+authors = ["ticki <Ticki@users.noreply.github.com>", "gycos <alexandre.bury@gmail.com>", "IGI-111 <igi-111@protonmail.com>"]
+description = "A bindless library for manipulating terminals."
+repository = "https://github.com/ticki/termion"
+documentation = "https://docs.rs/termion"
+license = "MIT"
+keywords = ["tty", "color", "terminal", "password", "tui"]
+exclude = ["target", "CHANGELOG.md", "image.png", "Cargo.lock"]
+
+[target.'cfg(not(target_os = "redox"))'.dependencies]
+libc = "0.2.8"
+
+[target.'cfg(target_os = "redox")'.dependencies]
+redox_syscall = "0.1"
+redox_termios = "0.1"