summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tinystr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/tinystr/Cargo.toml')
-rw-r--r--third_party/rust/tinystr/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/tinystr/Cargo.toml b/third_party/rust/tinystr/Cargo.toml
new file mode 100644
index 0000000000..ea491ae7d2
--- /dev/null
+++ b/third_party/rust/tinystr/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "tinystr"
+version = "0.3.2"
+authors = ["Raph Levien <raph.levien@gmail.com>", "Zibi Braniecki <zibi@braniecki.net>"]
+description = "A small ASCII-only bounded length string representation.\n"
+readme = "README.md"
+keywords = ["string", "str", "small", "tiny"]
+categories = ["data-structures"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/zbraniecki/tinystr"
+
+[[bench]]
+name = "construct"
+harness = false
+
+[[bench]]
+name = "tinystr"
+harness = false
+[dev-dependencies.criterion]
+version = "0.3"