summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio-0.1.11/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/tokio-0.1.11/Cargo.toml')
-rw-r--r--third_party/rust/tokio-0.1.11/Cargo.toml111
1 files changed, 111 insertions, 0 deletions
diff --git a/third_party/rust/tokio-0.1.11/Cargo.toml b/third_party/rust/tokio-0.1.11/Cargo.toml
new file mode 100644
index 0000000000..5cad3149b7
--- /dev/null
+++ b/third_party/rust/tokio-0.1.11/Cargo.toml
@@ -0,0 +1,111 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "tokio"
+version = "0.1.11"
+authors = ["Carl Lerche <me@carllerche.com>"]
+description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
+homepage = "https://tokio.rs"
+documentation = "https://docs.rs/tokio/0.1.11/tokio/"
+readme = "README.md"
+keywords = ["io", "async", "non-blocking", "futures"]
+categories = ["asynchronous", "network-programming"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+[dependencies.bytes]
+version = "0.4"
+
+[dependencies.futures]
+version = "0.1.20"
+
+[dependencies.mio]
+version = "0.6.14"
+
+[dependencies.tokio-async-await]
+version = "0.1.0"
+optional = true
+
+[dependencies.tokio-codec]
+version = "0.1.0"
+
+[dependencies.tokio-current-thread]
+version = "0.1.3"
+
+[dependencies.tokio-executor]
+version = "0.1.5"
+
+[dependencies.tokio-fs]
+version = "0.1.3"
+
+[dependencies.tokio-io]
+version = "0.1.6"
+
+[dependencies.tokio-reactor]
+version = "0.1.1"
+
+[dependencies.tokio-tcp]
+version = "0.1.0"
+
+[dependencies.tokio-threadpool]
+version = "0.1.4"
+
+[dependencies.tokio-timer]
+version = "0.2.6"
+
+[dependencies.tokio-udp]
+version = "0.1.0"
+[dev-dependencies.env_logger]
+version = "0.5"
+default-features = false
+
+[dev-dependencies.flate2]
+version = "1"
+features = ["tokio"]
+
+[dev-dependencies.futures-cpupool]
+version = "0.1"
+
+[dev-dependencies.http]
+version = "0.1"
+
+[dev-dependencies.httparse]
+version = "1.0"
+
+[dev-dependencies.libc]
+version = "0.2"
+
+[dev-dependencies.num_cpus]
+version = "1.0"
+
+[dev-dependencies.serde]
+version = "1.0"
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.time]
+version = "0.1"
+
+[features]
+async-await-preview = ["tokio-async-await/async-await-preview"]
+[target."cfg(unix)".dependencies.tokio-uds]
+version = "0.2.1"
+[badges.appveyor]
+id = "s83yxhy9qeb58va7"
+repository = "carllerche/tokio"
+
+[badges.travis-ci]
+repository = "tokio-rs/tokio"