summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio-util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/tokio-util/Cargo.toml')
-rw-r--r--third_party/rust/tokio-util/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/third_party/rust/tokio-util/Cargo.toml b/third_party/rust/tokio-util/Cargo.toml
new file mode 100644
index 0000000000..954d45552f
--- /dev/null
+++ b/third_party/rust/tokio-util/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "tokio-util"
+version = "0.2.0"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = "Additional utilities for working with Tokio.\n"
+homepage = "https://tokio.rs"
+documentation = "https://docs.rs/tokio-util/0.2.0/tokio_util"
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.bytes]
+version = "0.5.0"
+
+[dependencies.futures-core]
+version = "0.3.0"
+
+[dependencies.futures-sink]
+version = "0.3.0"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.pin-project-lite]
+version = "0.1.1"
+
+[dependencies.tokio]
+version = "0.2.0"
+[dev-dependencies.futures]
+version = "0.3.0"
+
+[dev-dependencies.tokio]
+version = "0.2.0"
+features = ["full"]
+
+[dev-dependencies.tokio-test]
+version = "0.2.0"
+
+[features]
+codec = []
+default = []
+full = ["codec", "udp"]
+udp = ["tokio/udp"]