summaryrefslogtreecommitdiffstats
path: root/third_party/rust/triple_buffer/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/triple_buffer/Cargo.toml')
-rw-r--r--third_party/rust/triple_buffer/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/third_party/rust/triple_buffer/Cargo.toml b/third_party/rust/triple_buffer/Cargo.toml
new file mode 100644
index 0000000000..1436dbb354
--- /dev/null
+++ b/third_party/rust/triple_buffer/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "triple_buffer"
+version = "5.0.5"
+authors = ["Hadrien G. <knights_of_ni@gmx.com>"]
+description = "An implementation of triple buffering, useful for sharing frequently updated data between threads"
+documentation = "https://docs.rs/triple_buffer/"
+readme = "README.md"
+keywords = ["synchronization", "spsc", "multithreading", "non-blocking", "wait-free"]
+categories = ["algorithms", "asynchronous", "concurrency", "data-structures"]
+license = "MPL-2.0"
+repository = "https://github.com/HadrienG2/triple-buffer"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.cache-padded]
+version = "1.1"
+[dev-dependencies.testbench]
+version = "0.7"
+
+[features]
+raw = []
+[badges.maintenance]
+status = "passively-maintained"