summaryrefslogtreecommitdiffstats
path: root/third_party/rust/zip/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/zip/Cargo.toml')
-rw-r--r--third_party/rust/zip/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/zip/Cargo.toml b/third_party/rust/zip/Cargo.toml
new file mode 100644
index 0000000000..c8ea4e0927
--- /dev/null
+++ b/third_party/rust/zip/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "zip"
+version = "0.4.2"
+authors = ["Mathijs van de Nes <git@mathijs.vd-nes.nl>"]
+description = "Library to support the reading and writing of zip files.\n"
+documentation = "http://mvdnes.github.io/rust-docs/zip-rs/zip/index.html"
+keywords = ["zip", "archive"]
+license = "MIT"
+repository = "https://github.com/mvdnes/zip-rs.git"
+[dependencies.bzip2]
+version = "0.3"
+optional = true
+
+[dependencies.flate2]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.msdos_time]
+version = "0.1"
+
+[dependencies.podio]
+version = "0.1"
+
+[dependencies.time]
+version = "0.1"
+[dev-dependencies.walkdir]
+version = "1.0"
+
+[features]
+default = ["bzip2", "deflate"]
+deflate = ["flate2", "flate2/rust_backend"]
+deflate-miniz = ["flate2", "flate2/miniz-sys"]
+deflate-zlib = ["flate2", "flate2/zlib"]