summaryrefslogtreecommitdiffstats
path: root/toolkit/components/places/bookmark_sync/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/components/places/bookmark_sync/Cargo.toml')
-rw-r--r--toolkit/components/places/bookmark_sync/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/toolkit/components/places/bookmark_sync/Cargo.toml b/toolkit/components/places/bookmark_sync/Cargo.toml
new file mode 100644
index 0000000000..9b2c4f3137
--- /dev/null
+++ b/toolkit/components/places/bookmark_sync/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "bookmark_sync"
+version = "0.1.0"
+authors = ["Lina Cambridge <lina@yakshaving.ninja>"]
+edition = "2018"
+
+[dependencies]
+atomic_refcell = "0.1"
+dogear = "0.4.0"
+libc = "0.2"
+log = "0.4"
+cstr = "0.2"
+moz_task = { path = "../../../../xpcom/rust/moz_task" }
+nserror = { path = "../../../../xpcom/rust/nserror" }
+nsstring = { path = "../../../../xpcom/rust/nsstring" }
+storage = { path = "../../../../storage/rust" }
+storage_variant = { path = "../../../../storage/variant" }
+url = "2.0"
+xpcom = { path = "../../../../xpcom/rust/xpcom" }
+
+[dependencies.thin-vec]
+version = "0.2.1"
+features = ["gecko-ffi"]