summaryrefslogtreecommitdiffstats
path: root/tools/profiler/rust-helper/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/profiler/rust-helper/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/profiler/rust-helper/Cargo.toml b/tools/profiler/rust-helper/Cargo.toml
new file mode 100644
index 0000000000..28f8276ee1
--- /dev/null
+++ b/tools/profiler/rust-helper/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "profiler_helper"
+version = "0.1.0"
+authors = ["Markus Stange <mstange@themasta.com>"]
+
+[dependencies]
+memmap = "0.7"
+rustc-demangle = "0.1"
+uuid = "0.8"
+
+[dependencies.object]
+version = "0.16"
+optional = true
+default-features = false
+features = ["std", "read"]
+
+[dependencies.goblin]
+optional = true
+# The version and features of goblin need to match what's in object's Cargo.toml,
+# because we really want object's goblin and not another instance of goblin.
+version = "0.1"
+features = ["endian_fd", "elf32", "elf64", "mach32", "mach64", "pe32", "pe64", "archive"]
+default-features = false
+
+[dependencies.thin-vec]
+version = "0.2.1"
+features = ["gecko-ffi"]
+
+[features]
+parse_elf = ["object", "goblin"]