summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:30:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:30:14 +0000
commitf38bddc70a6ec7c1ab26d9a8b06eed25d618ae22 (patch)
tree6437d0de9ba7fb9b0933a7c0eaa610a404d79e4e /tests/meson.build
parentInitial commit. (diff)
downloadgdm3-f38bddc70a6ec7c1ab26d9a8b06eed25d618ae22.tar.xz
gdm3-f38bddc70a6ec7c1ab26d9a8b06eed25d618ae22.zip
Adding upstream version 3.38.2.1.upstream/3.38.2.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..128b5d2
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,17 @@
+m_common_test_src = [
+ 'm-common.c',
+ 's-common-address.c',
+ 's-common.c',
+]
+
+m_common_test_deps = [
+ libgdmcommon_dep,
+ libcheck_dep,
+]
+
+m_common_test = executable('m-common',
+ m_common_test_src,
+ dependencies: m_common_test_deps,
+)
+
+test('m-common', m_common_test)