summaryrefslogtreecommitdiffstats
path: root/plugins/externaltools/tests/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:32:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:32:59 +0000
commitadb934701975f6b0214475d1a8d0d1ce727b9d4d (patch)
tree5688c745d10b64c8856586864ec416a6bdae881d /plugins/externaltools/tests/meson.build
parentInitial commit. (diff)
downloadgedit-upstream/3.38.1.tar.xz
gedit-upstream/3.38.1.zip
Adding upstream version 3.38.1.upstream/3.38.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plugins/externaltools/tests/meson.build')
-rw-r--r--plugins/externaltools/tests/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/externaltools/tests/meson.build b/plugins/externaltools/tests/meson.build
new file mode 100644
index 0000000..6cee9fe
--- /dev/null
+++ b/plugins/externaltools/tests/meson.build
@@ -0,0 +1,21 @@
+externaltools_tests = {
+ 'LinkParser': files('testlinkparsing.py'),
+}
+
+externaltools_srcdir = join_paths(
+ srcdir,
+ 'plugins',
+ 'externaltools',
+ 'tools',
+)
+
+foreach test_name, test_script : externaltools_tests
+ test(
+ 'test-externaltools-@0@'.format(test_name),
+ python3,
+ args: [test_script],
+ env: [
+ 'PYTHONPATH=@0@'.format(externaltools_srcdir),
+ ]
+ )
+endforeach