summaryrefslogtreecommitdiffstats
path: root/build-aux/osx/build/updater/patches/gedit-plugins-disable-terminal.patch
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--build-aux/osx/build/updater/patches/gedit-plugins-disable-terminal.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/build-aux/osx/build/updater/patches/gedit-plugins-disable-terminal.patch b/build-aux/osx/build/updater/patches/gedit-plugins-disable-terminal.patch
new file mode 100644
index 0000000..e1d2928
--- /dev/null
+++ b/build-aux/osx/build/updater/patches/gedit-plugins-disable-terminal.patch
@@ -0,0 +1,30 @@
+--- a/configure.ac 2011-10-16 22:03:19.000000000 +0200
++++ b/configure.ac 2012-01-15 13:57:54.000000000 +0100
+@@ -246,6 +246,27 @@
+ fi
+ fi
+
++# ================================================================
++# Terminal (vte)
++# ================================================================
++plugin_defined terminal
++
++if test "$?" = 1
++then
++ AC_CHECK_LIB([vte], [vte_terminal_new], [have_vte=yes], [have_vte=no])
++
++ if test "x$have_vte" = "xno"; then
++ plugin_defined_explicit terminal
++ if test "$?" = 1
++ then
++ AC_MSG_ERROR([vte could not be found, needed for terminal plugin])
++ else
++ AC_MSG_WARN([vte could not be found, terminal plugin will be disabled])
++ undef_plugin terminal "vte not found"
++ fi
++ fi
++fi
++
+ if test -z "$disabled_plugins"
+ then
+ disabled_plugins="none"