summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules45
1 files changed, 45 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7b13e6c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,45 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
+
+# needed with the Ubuntu toolchain to avoid plugin issues
+export DEB_LDFLAGS_MAINT_STRIP := -Wl,-Bsymbolic-functions
+
+%:
+ dh $@ --with gir,gnome,python3
+
+override_dh_auto_configure:
+ dh_auto_configure -- -Dgtk_doc=true
+
+override_dh_python3:
+ dh_python3
+ dh_python3 /usr/lib/$(DEB_HOST_MULTIARCH)/gedit/plugins
+ dh_python3 /usr/share/gedit/plugins
+
+override_dh_girepository:
+ dh_girepository -ldebian/tmp/usr/share/gedit/gir-1.0 \
+ /usr/lib/$(DEB_HOST_MULTIARCH)/gedit/girepository-1.0 \
+ /usr/lib/$(DEB_HOST_MULTIARCH)/gedit
+
+override_dh_install:
+ # remove cruft
+ find debian/tmp -name '*.la' -print -delete
+ rm -rf debian/tmp/usr/lib/*/gedit/plugins/*/__pycache__/
+ # remove gnome-text-editor symlink, it's registered in the
+ # debian alternatives system instead. See postinst.
+ rm -f debian/tmp/usr/bin/gnome-text-editor
+ dh_install
+
+override_dh_fixperms-indep:
+ dh_fixperms -i
+ chmod 0755 debian/gedit-common/usr/share/gedit/plugins/externaltools/tools/*
+
+override_dh_missing:
+ dh_missing --fail-missing
+
+override_dh_shlibdeps:
+ dh_shlibdeps -l/usr/lib/$(DEB_HOST_MULTIARCH)/gedit
+
+override_dh_makeshlibs:
+ dh_makeshlibs --no-scripts