summaryrefslogtreecommitdiffstats
path: root/t/perf/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:49:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:49:36 +0000
commit5ec6074f0633939fd17d94111d10c6c6b062978c (patch)
treebfaa17b5a64abc66c918e9c70969e519d9e1df8e /t/perf/Makefile
parentInitial commit. (diff)
downloadgit-upstream.tar.xz
git-upstream.zip
Adding upstream version 1:2.30.2.upstream/1%2.30.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/perf/Makefile')
-rw-r--r--t/perf/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/t/perf/Makefile b/t/perf/Makefile
new file mode 100644
index 0000000..fcb0e88
--- /dev/null
+++ b/t/perf/Makefile
@@ -0,0 +1,18 @@
+-include ../../config.mak
+export GIT_TEST_OPTIONS
+
+all: test-lint perf
+
+perf: pre-clean
+ ./run
+
+pre-clean:
+ rm -rf test-results
+
+clean:
+ rm -rf build "trash directory".* test-results
+
+test-lint:
+ $(MAKE) -C .. test-lint
+
+.PHONY: all perf pre-clean clean