summaryrefslogtreecommitdiffstats
path: root/t/perf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 't/perf/Makefile')
-rw-r--r--t/perf/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/t/perf/Makefile b/t/perf/Makefile
new file mode 100644
index 0000000..fcb0e88
--- /dev/null
+++ b/t/perf/Makefile
@@ -0,0 +1,18 @@
+-include ../../config.mak
+export GIT_TEST_OPTIONS
+
+all: test-lint perf
+
+perf: pre-clean
+ ./run
+
+pre-clean:
+ rm -rf test-results
+
+clean:
+ rm -rf build "trash directory".* test-results
+
+test-lint:
+ $(MAKE) -C .. test-lint
+
+.PHONY: all perf pre-clean clean