summaryrefslogtreecommitdiffstats
path: root/tests/printers/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:36:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:36:24 +0000
commit9b6d8e63db85c30007b463e91f91a791969fa83f (patch)
tree0899af51d73c1bf986f73ae39a03c4436083018a /tests/printers/meson.build
parentInitial commit. (diff)
downloadgnome-control-center-upstream.tar.xz
gnome-control-center-upstream.zip
Adding upstream version 1:3.38.4.upstream/1%3.38.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/printers/meson.build')
-rw-r--r--tests/printers/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/printers/meson.build b/tests/printers/meson.build
new file mode 100644
index 0000000..60f144f
--- /dev/null
+++ b/tests/printers/meson.build
@@ -0,0 +1,22 @@
+
+test_units = [
+ #'test-canonicalization',
+ 'test-shift'
+]
+
+includes = [top_inc, include_directories('../../panels/printers')]
+cflags = '-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir())
+
+foreach unit: test_units
+ exe = executable(
+ unit,
+ [unit + '.c'],
+ include_directories : includes,
+ dependencies : common_deps,
+ link_with : [printers_panel_lib],
+ c_args : cflags
+ )
+
+ test(unit, exe)
+endforeach
+