summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch23
-rw-r--r--debian/patches/Expose-touchpad-settings-if-synaptics-is-in-use.patch88
-rw-r--r--debian/patches/Revert-build-Bump-build-dependency-on-polkit.patch22
-rw-r--r--debian/patches/distro-logo.patch29
-rw-r--r--debian/patches/series4
5 files changed, 166 insertions, 0 deletions
diff --git a/debian/patches/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch b/debian/patches/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch
new file mode 100644
index 0000000..e340a4d
--- /dev/null
+++ b/debian/patches/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch
@@ -0,0 +1,23 @@
+From: Andrea Azzarone <andrea.azzarone@canonical.com>
+Date: Tue, 31 Jul 2018 04:44:11 +0100
+Subject: Debian's adduser doesn't allow uppercase letters by default.
+
+Forwarded: no
+Bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910141
+---
+ panels/user-accounts/cc-add-user-dialog.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/panels/user-accounts/cc-add-user-dialog.c b/panels/user-accounts/cc-add-user-dialog.c
+index 7a99b09..201ac41 100644
+--- a/panels/user-accounts/cc-add-user-dialog.c
++++ b/panels/user-accounts/cc-add-user-dialog.c
+@@ -234,7 +234,7 @@ local_create_user (CcAddUserDialog *self)
+
+ manager = act_user_manager_get_default ();
+ act_user_manager_create_user_async (manager,
+- username,
++ g_ascii_strdown (username, -1),
+ name,
+ account_type,
+ self->cancellable,
diff --git a/debian/patches/Expose-touchpad-settings-if-synaptics-is-in-use.patch b/debian/patches/Expose-touchpad-settings-if-synaptics-is-in-use.patch
new file mode 100644
index 0000000..6f106ad
--- /dev/null
+++ b/debian/patches/Expose-touchpad-settings-if-synaptics-is-in-use.patch
@@ -0,0 +1,88 @@
+From: Daniel van Vugt <daniel.van.vugt@canonical.com>
+Date: Fri, 16 Mar 2018 13:53:10 -0400
+Subject: [PATCH 01/22] Expose touchpad settings if synaptics is in use
+
+Upstream is aggressively pushing for libinput over synaptics. However that
+creates a factually incorrect situation where gnome-control-center thinks
+there is no touchpad unless you're using the xserver-xorg-input-libinput.
+This patch adds support for both drivers, removing the code that would
+hide the touchpad settings when xserver-xorg-input-synaptics is in use.
+
+This patch is only useful in the GNOME on Xorg session.
+In GNOME on Wayland, libinput is used anyway.
+
+This patch requires a companion patch in mutter which GNOME has rejected.
+
+https://gitlab.gnome.org/GNOME/mutter/merge_requests/37
+---
+ panels/mouse/cc-mouse-caps-helper.c | 7 +++++++
+ panels/mouse/cc-mouse-panel.c | 16 +++++++++-------
+ 2 files changed, 16 insertions(+), 7 deletions(-)
+
+diff --git a/panels/mouse/cc-mouse-caps-helper.c b/panels/mouse/cc-mouse-caps-helper.c
+index 69546b2..39534b9 100644
+--- a/panels/mouse/cc-mouse-caps-helper.c
++++ b/panels/mouse/cc-mouse-caps-helper.c
+@@ -38,6 +38,13 @@ touchpad_check_capabilities_x11 (gboolean *have_two_finger_scrolling,
+ unsigned long nitems, bytes_after;
+ unsigned char *data;
+
++ if (cc_synaptics_check ()) {
++ *have_two_finger_scrolling = TRUE;
++ *have_edge_scrolling = TRUE;
++ *have_tap_to_click = TRUE;
++ return TRUE;
++ }
++
+ gdisplay = gdk_display_get_default ();
+ display = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
+ prop_scroll_methods = XInternAtom (display, "libinput Scroll Methods Available", False);
+diff --git a/panels/mouse/cc-mouse-panel.c b/panels/mouse/cc-mouse-panel.c
+index a7f018b..08304bf 100644
+--- a/panels/mouse/cc-mouse-panel.c
++++ b/panels/mouse/cc-mouse-panel.c
+@@ -68,7 +68,6 @@ struct _CcMousePanel
+ gboolean have_mouse;
+ gboolean have_touchpad;
+ gboolean have_touchscreen;
+- gboolean have_synaptics;
+
+ gboolean left_handed;
+ GtkGesture *left_gesture;
+@@ -86,7 +85,7 @@ setup_touchpad_options (CcMousePanel *self)
+ gboolean have_edge_scrolling;
+ gboolean have_tap_to_click;
+
+- if (self->have_synaptics || !self->have_touchpad) {
++ if (!self->have_touchpad) {
+ gtk_widget_hide (GTK_WIDGET (self->touchpad_frame));
+ return;
+ }
+@@ -308,7 +307,10 @@ setup_dialog (CcMousePanel *self)
+ static void
+ device_changed (CcMousePanel *self)
+ {
+- self->have_touchpad = touchpad_is_present ();
++ self->have_touchpad = touchpad_is_present () || cc_synaptics_check ();
++ /* ^^^^^^^^^^^^^^^^^^^^^
++ * Workaround https://gitlab.gnome.org/GNOME/gtk/issues/97
++ */
+
+ setup_touchpad_options (self);
+
+@@ -397,11 +399,11 @@ cc_mouse_panel_init (CcMousePanel *self)
+ G_CALLBACK (device_changed), self, G_CONNECT_SWAPPED);
+
+ self->have_mouse = mouse_is_present ();
+- self->have_touchpad = touchpad_is_present ();
++ self->have_touchpad = touchpad_is_present () || cc_synaptics_check ();
++ /* ^^^^^^^^^^^^^^^^^^^^^
++ * Workaround https://gitlab.gnome.org/GNOME/gtk/issues/97
++ */
+ self->have_touchscreen = touchscreen_is_present ();
+- self->have_synaptics = cc_synaptics_check ();
+- if (self->have_synaptics)
+- g_warning ("Detected synaptics X driver, please migrate to libinput");
+
+ setup_dialog (self);
+ }
diff --git a/debian/patches/Revert-build-Bump-build-dependency-on-polkit.patch b/debian/patches/Revert-build-Bump-build-dependency-on-polkit.patch
new file mode 100644
index 0000000..18fec05
--- /dev/null
+++ b/debian/patches/Revert-build-Bump-build-dependency-on-polkit.patch
@@ -0,0 +1,22 @@
+From: Laurent Bigonville <bigon@debian.org>
+Date: Tue, 10 Mar 2020 19:10:35 +0100
+Subject: Revert "build: Bump build-dependency on polkit"
+
+This reverts commit 9ebcd17236a54daa0927a22d973d0309dfb4c8df.
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index a8984fd..d2e15ed 100644
+--- a/meson.build
++++ b/meson.build
+@@ -127,7 +127,7 @@ gnome_settings_dep = dependency('gnome-settings-daemon', version: '>= 3.27.90')
+ goa_dep = dependency('goa-1.0', version: goa_req_version)
+ gsettings_desktop_dep = dependency('gsettings-desktop-schemas', version: '>= 3.37.1')
+ libxml_dep = dependency('libxml-2.0')
+-polkit_gobject_dep = dependency('polkit-gobject-1', version: '>= 0.114')
++polkit_gobject_dep = dependency('polkit-gobject-1', version: '>= 0.103')
+ pulse_dep = dependency('libpulse', version: pulse_req_version)
+ pulse_mainloop_dep = dependency('libpulse-mainloop-glib', version: pulse_req_version)
+ upower_glib_dep = dependency('upower-glib', version: '>= 0.99.8')
diff --git a/debian/patches/distro-logo.patch b/debian/patches/distro-logo.patch
new file mode 100644
index 0000000..47e28e5
--- /dev/null
+++ b/debian/patches/distro-logo.patch
@@ -0,0 +1,29 @@
+From: Bastien Nocera <hadess@hadess.net>
+Date: Mon, 3 Feb 2020 14:46:15 +0100
+Subject: [PATCH 03/22] info-overview: Use the Ubuntu logo prominently
+
+This removes GNOME branding in favour of Ubuntu branding. We don't
+make changes to the text information as the distribution/OS is clearly
+visible above the GNOME version.
+
+See https://bugzilla.gnome.org/show_bug.cgi?id=695691
+
+(Patch taken from Fedora and updated for Ubuntu)
+---
+ panels/info-overview/cc-info-overview-panel.ui | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/panels/info-overview/cc-info-overview-panel.ui b/panels/info-overview/cc-info-overview-panel.ui
+index 98cb85d..cac8567 100644
+--- a/panels/info-overview/cc-info-overview-panel.ui
++++ b/panels/info-overview/cc-info-overview-panel.ui
+@@ -28,7 +28,8 @@
+ <object class="GtkImage">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+- <property name="resource">/org/gnome/control-center/info-overview/GnomeLogoVerticalMedium.svg</property>
++ <property name="pixel_size">128</property>
++ <property name="pixbuf">/usr/share/icons/vendor/scalable/emblems/emblem-vendor.svg</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..0a5bfff
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,4 @@
+Expose-touchpad-settings-if-synaptics-is-in-use.patch
+Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch
+distro-logo.patch
+Revert-build-Bump-build-dependency-on-polkit.patch