summaryrefslogtreecommitdiffstats
path: root/subprojects/libhandy/doc/xml/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--subprojects/libhandy/doc/xml/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/subprojects/libhandy/doc/xml/meson.build b/subprojects/libhandy/doc/xml/meson.build
new file mode 100644
index 0000000..5f73097
--- /dev/null
+++ b/subprojects/libhandy/doc/xml/meson.build
@@ -0,0 +1,12 @@
+ent_conf = configuration_data()
+ent_conf.set('PACKAGE', 'Handy')
+ent_conf.set('PACKAGE_BUGREPORT', 'https://gitlab.gnome.org/GNOME/libhandy/issues')
+ent_conf.set('PACKAGE_NAME', 'Handy')
+ent_conf.set('PACKAGE_STRING', 'libhandy')
+ent_conf.set('PACKAGE_TARNAME', 'libhandy-' + meson.project_version())
+ent_conf.set('PACKAGE_URL', 'https://gitlab.gnome.org/GNOME/libhandy')
+ent_conf.set('PACKAGE_VERSION', meson.project_version())
+ent_conf.set('PACKAGE_API_VERSION', apiversion)
+ent_conf.set('PACKAGE_API_NAME', package_api_name)
+configure_file(input: 'gtkdocentities.ent.in', output: 'gtkdocentities.ent', configuration: ent_conf)
+