summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:09:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:09:05 +0000
commitca60a76df5ae992d4e32a15d1ce34e02ca357198 (patch)
treebce7bbfbcb57785f417eb17f7bda0a8004495143 /debian/rules
parentAdding upstream version 3.38.4. (diff)
downloadgnome-initial-setup-ca60a76df5ae992d4e32a15d1ce34e02ca357198.tar.xz
gnome-initial-setup-ca60a76df5ae992d4e32a15d1ce34e02ca357198.zip
Adding debian version 3.38.4-1.debian/3.38.4-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules36
1 files changed, 36 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..dfccc5b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,36 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,defs -Wl,--as-needed
+
+%:
+ dh $@
+
+ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64))
+PARENTAL_CONTROL := -Dparental_controls=enabled
+else
+PARENTAL_CONTROL := -Dparental_controls=disabled
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Dauto_features=enabled \
+ $(PARENTAL_CONTROL) \
+ -Dvendor-conf-file=/usr/lib/gnome-initial-setup/vendor.conf
+
+# Skip language chooser on Ubuntu since it doesn't work there
+override_dh_install:
+ dh_install
+ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
+ dh_install debian/vendor.conf /usr/lib/gnome-initial-setup
+endif
+
+# Depend on the appropriate package for the Welcome logo
+override_dh_gencontrol:
+ifeq ($(shell dpkg-vendor --query vendor),Debian)
+ dh_gencontrol -- -Vlogo:Depends='desktop-base'
+else ifeq ($(shell dpkg-vendor --query vendor),Ubuntu)
+ dh_gencontrol -- -Vlogo:Depends='gnome-control-center-data'
+else
+ dh_gencontrol
+endif