summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:41:01 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:41:01 +0000
commit1a2738532d1c95e1d48701628cd81ca96c267761 (patch)
treea67781318e259d176e6d6d056501bc6a372a8453 /debian/rules
parentAdding upstream version 3.38.0. (diff)
downloadgnome-session-1a2738532d1c95e1d48701628cd81ca96c267761.tar.xz
gnome-session-1a2738532d1c95e1d48701628cd81ca96c267761.zip
Adding debian version 3.38.0-4.debian/3.38.0-4debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..344ac70
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs -Wl,--as-needed
+
+%:
+ dh $@ --with gnome
+
+ifeq (linux,$(DEB_HOST_ARCH_OS))
+CONFFLAGS = -Dsystemd=true -Dsystemd_journal=true -Dsystemd_session=enable
+else
+CONFFLAGS = -Dsystemd=false -Dsystemd_journal=false -Dsystemd_session=disable
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Dman=true \
+ $(CONFFLAGS)
+
+override_dh_auto_install:
+ dh_auto_install
+ # Remove this when gdm3 and gnome-control-center have caught up
+ mkdir -p debian/tmp/usr/lib/gnome-session
+ ( cd debian/tmp/usr/lib/gnome-session && ln -s ../../libexec/* . )
+