summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..344ac70
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs -Wl,--as-needed
+
+%:
+ dh $@ --with gnome
+
+ifeq (linux,$(DEB_HOST_ARCH_OS))
+CONFFLAGS = -Dsystemd=true -Dsystemd_journal=true -Dsystemd_session=enable
+else
+CONFFLAGS = -Dsystemd=false -Dsystemd_journal=false -Dsystemd_session=disable
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Dman=true \
+ $(CONFFLAGS)
+
+override_dh_auto_install:
+ dh_auto_install
+ # Remove this when gdm3 and gnome-control-center have caught up
+ mkdir -p debian/tmp/usr/lib/gnome-session
+ ( cd debian/tmp/usr/lib/gnome-session && ln -s ../../libexec/* . )
+