summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:59:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:59:21 +0000
commitd8d06026cb993d02e6ab2304fabbda3b60d940b2 (patch)
treeba4d8c052c5ba93cbef35b46060e61fd737ed9af /Makefile
parentInitial commit. (diff)
downloadgnome-shell-extension-impatience-d8d06026cb993d02e6ab2304fabbda3b60d940b2.tar.xz
gnome-shell-extension-impatience-d8d06026cb993d02e6ab2304fabbda3b60d940b2.zip
Adding upstream version 0.4.5.upstream/0.4.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..5d256bf
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+all: schemas zip
+
+0: phony
+ mkzero-gfxmonk -p impatience -p xdg gnome-shell-impatience.xml
+
+schemas: phony
+ cd impatience/schemas && glib-compile-schemas .
+
+zip: phony
+ rm impatience@gfxmonk.net.zip
+ cd impatience && zip -r ../impatience@gfxmonk.net.zip *
+
+.PHONY: phony