summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:05:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:05:15 +0000
commit08ea29ecd16f0acf41bef66651866eb22878e3b6 (patch)
tree348f7a390181b98e67183bb808c73110e3457a06 /debian/rules
parentAdding upstream version 23. (diff)
downloadgnome-shell-extension-multi-monitors-f0b5f858eb0165915a74a3e9cc677810b8e2f052.tar.xz
gnome-shell-extension-multi-monitors-f0b5f858eb0165915a74a3e9cc677810b8e2f052.zip
Adding debian version 23-1.debian/23-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..114c733
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ # Build translations
+ for TRANSLATION in multi-monitors-add-on@spin83/locale/* ; do \
+ echo "Processing $$TRANSLATION..."; \
+ msgfmt -cv -o $$TRANSLATION/LC_MESSAGES/multi-monitors-add-on.mo \
+ $$TRANSLATION/LC_MESSAGES/multi-monitors-add-on.po; \
+ done
+ # Compile gschemas so that we don't ship upstream compiled version
+ glib-compile-schemas --strict --targetdir=multi-monitors-add-on@spin83/schemas/ multi-monitors-add-on@spin83/schemas
+ dh_auto_build