summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..114c733
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ # Build translations
+ for TRANSLATION in multi-monitors-add-on@spin83/locale/* ; do \
+ echo "Processing $$TRANSLATION..."; \
+ msgfmt -cv -o $$TRANSLATION/LC_MESSAGES/multi-monitors-add-on.mo \
+ $$TRANSLATION/LC_MESSAGES/multi-monitors-add-on.po; \
+ done
+ # Compile gschemas so that we don't ship upstream compiled version
+ glib-compile-schemas --strict --targetdir=multi-monitors-add-on@spin83/schemas/ multi-monitors-add-on@spin83/schemas
+ dh_auto_build