summaryrefslogtreecommitdiffstats
path: root/docs/reference/shell/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
commitf9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7 (patch)
treece9e8db2d4e8799780fa72ae8f1953039373e2ee /docs/reference/shell/meson.build
parentInitial commit. (diff)
downloadgnome-shell-f9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7.tar.xz
gnome-shell-f9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7.zip
Adding upstream version 3.38.6.upstream/3.38.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--docs/reference/shell/meson.build51
1 files changed, 51 insertions, 0 deletions
diff --git a/docs/reference/shell/meson.build b/docs/reference/shell/meson.build
new file mode 100644
index 0000000..5936ea3
--- /dev/null
+++ b/docs/reference/shell/meson.build
@@ -0,0 +1,51 @@
+private_headers = [
+ 'gactionmuxer.h',
+ 'gactionobservable.h',
+ 'gactionobserver.h',
+ 'shell-network-agent.h',
+]
+
+exclude_directories = [
+ 'calendar-server',
+ 'hotplug-sniffer',
+ 'st',
+ 'tray'
+]
+
+ifaces = [
+ ['org.gnome.Shell.Screenshot', 'org.gnome.Shell.Screenshot.xml'],
+ ['org.gnome.ShellSearchProvider', 'org.gnome.Shell.SearchProvider.xml'],
+ ['org.gnome.ShellSearchProvider2', 'org.gnome.Shell.SearchProvider2.xml']
+]
+foreach iface : ifaces
+ custom_target(iface[0] + ' docs',
+ input: '../../../data/dbus-interfaces/@0@.xml'.format(iface[0]),
+ output: 'doc-gen-' + iface[1],
+ command: [
+ 'gdbus-codegen',
+ '--interface-prefix=@0@.'.format(iface[0]),
+ '--generate-docbook', 'doc-gen',
+ '--output-directory', '@OUTDIR@',
+ '@INPUT@'
+ ],
+ build_by_default: true
+ )
+endforeach
+
+configure_file(
+ input: 'version.xml.in',
+ output: 'version.xml',
+ configuration: version_conf
+)
+
+gnome.gtkdoc('shell',
+ main_sgml: 'shell-docs.sgml',
+ src_dir: [
+ join_paths(meson.source_root(), 'src'),
+ join_paths(meson.build_root(), 'src')
+ ],
+ scan_args: [
+ '--ignore-headers=' + ' '.join(private_headers + exclude_directories)
+ ],
+ install: true
+)