summaryrefslogtreecommitdiffstats
path: root/js/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
commitf9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7 (patch)
treece9e8db2d4e8799780fa72ae8f1953039373e2ee /js/meson.build
parentInitial commit. (diff)
downloadgnome-shell-f9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7.tar.xz
gnome-shell-f9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7.zip
Adding upstream version 3.38.6.upstream/3.38.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--js/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/js/meson.build b/js/meson.build
new file mode 100644
index 0000000..4809f82
--- /dev/null
+++ b/js/meson.build
@@ -0,0 +1,16 @@
+subdir('misc')
+subdir('dbusServices')
+
+js_resources = gnome.compile_resources(
+ 'js-resources', 'js-resources.gresource.xml',
+ source_dir: ['.', meson.current_build_dir()],
+ c_name: 'shell_js_resources',
+ dependencies: [config_js]
+)
+
+portal_resources = gnome.compile_resources(
+ 'portal-resources', 'portal-resources.gresource.xml',
+ source_dir: ['.', meson.current_build_dir()],
+ c_name: 'portal_js_resources',
+ dependencies: [config_js]
+)