summaryrefslogtreecommitdiffstats
path: root/man/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
commitf9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7 (patch)
treece9e8db2d4e8799780fa72ae8f1953039373e2ee /man/meson.build
parentInitial commit. (diff)
downloadgnome-shell-upstream/3.38.6.tar.xz
gnome-shell-upstream/3.38.6.zip
Adding upstream version 3.38.6.upstream/3.38.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--man/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/man/meson.build b/man/meson.build
new file mode 100644
index 0000000..9d39a38
--- /dev/null
+++ b/man/meson.build
@@ -0,0 +1,19 @@
+custom_target('man page',
+ input: 'gnome-shell.xml',
+ output: 'gnome-shell.1',
+ command: [
+ xsltproc,
+ '-o', '@OUTPUT@',
+ '--nonet',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'funcsynopsis.style', 'ansi',
+ '--stringparam', 'man.th.extra1.suppress', '1',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
+ '@INPUT@'
+ ],
+ build_by_default: true,
+ install_dir: mandir + '/man1',
+ install: true
+)