summaryrefslogtreecommitdiffstats
path: root/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/man/meson.build b/man/meson.build
new file mode 100644
index 0000000..9d39a38
--- /dev/null
+++ b/man/meson.build
@@ -0,0 +1,19 @@
+custom_target('man page',
+ input: 'gnome-shell.xml',
+ output: 'gnome-shell.1',
+ command: [
+ xsltproc,
+ '-o', '@OUTPUT@',
+ '--nonet',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'funcsynopsis.style', 'ansi',
+ '--stringparam', 'man.th.extra1.suppress', '1',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
+ '@INPUT@'
+ ],
+ build_by_default: true,
+ install_dir: mandir + '/man1',
+ install: true
+)