summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..90cf859
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs -Wl,--as-needed
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+CONFFLAGS = -Dsystemd=true
+else
+CONFFLAGS = -Dsystemd=false
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- $(CONFFLAGS)
+
+override_dh_auto_build:
+ dh_auto_build
+ docbook-to-man debian/gnome-system-monitor.sgml \
+ > debian/gnome-system-monitor.1
+
+override_dh_auto_clean:
+ rm -f debian/gnome-system-monitor.1
+
+override_dh_installchangelogs:
+ dh_installchangelogs -XChangeLog