summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:21:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:21:33 +0000
commitc5086c67a3e6c18e539f1d4dd6f1da187c080fe9 (patch)
tree83fb83803b72b57475128d52de600b886235d6c1 /debian/rules
parentAdding upstream version 3.38.3. (diff)
downloadgnome-terminal-c5086c67a3e6c18e539f1d4dd6f1da187c080fe9.tar.xz
gnome-terminal-c5086c67a3e6c18e539f1d4dd6f1da187c080fe9.zip
Adding debian version 3.38.3-1.debian/3.38.3-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ba5f513
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_autoreconf:
+ dh_autoreconf --as-needed
+
+override_dh_install:
+ find debian/tmp -name '*.a' -print -delete
+ find debian/tmp -name '*.la' -print -delete
+ dh_install
+
+override_dh_missing:
+ dh_missing --fail-missing