summaryrefslogtreecommitdiffstats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..0de0868
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,53 @@
+NULL =
+
+public_icons_themes = hicolor
+
+dist_noinst_DATA = \
+ hicolor_apps_scalable_org.gnome.Terminal.svg \
+ hicolor_apps_symbolic_org.gnome.Terminal-symbolic.svg \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(NULL)
+
+install-public-icons:
+ for icon in $(dist_noinst_DATA); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ $(MKDIR_P) $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+uninstall-public-icons:
+ -for icon in $(dist_noinst_DATA); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ rm -f $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+install-data-local: install-public-icons
+uninstall-local: uninstall-public-icons
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t
+
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ for theme in $(public_icons_themes); do \
+ $(gtk_update_icon_cache) $(datadir)/icons/$$theme; \
+ done; \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ for theme in $(public_icons_themes); do \
+ echo "*** $(gtk_update_icon_cache) $(datadir)/icons/$$theme"; \
+ done; \
+ fi
+
+-include $(top_srcdir)/git.mk