summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-04 15:19:07 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-04 15:19:07 +0000
commit53852222f76eaea897e912edb5195296c6ced89b (patch)
tree0a39889e196d70e327b6f0c632faea5c2a030331
parentReleasing progress-linux version 2.2.27-2+deb11u1progress6u1. (diff)
downloadgnupg2-53852222f76eaea897e912edb5195296c6ced89b.tar.xz
gnupg2-53852222f76eaea897e912edb5195296c6ced89b.zip
Merging debian version 2.2.27-2+deb11u2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/cherry-picked/g10-Fix-garbled-status-messages-in-NOTATION_DATA.patch47
-rw-r--r--debian/patches/series1
3 files changed, 54 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d967871..a0855b9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gnupg2 (2.2.27-2+deb11u2) bullseye-security; urgency=high
+
+ * fix broken status line (Closes: #1014157)
+
+ -- Daniel Kahn Gillmor <dkg@fifthhorseman.net> Fri, 01 Jul 2022 03:03:46 -0400
+
gnupg2 (2.2.27-2+deb11u1progress6u1) fuchur; urgency=medium
* Uploading to fuchur, remaining changes:
diff --git a/debian/patches/cherry-picked/g10-Fix-garbled-status-messages-in-NOTATION_DATA.patch b/debian/patches/cherry-picked/g10-Fix-garbled-status-messages-in-NOTATION_DATA.patch
new file mode 100644
index 0000000..d66b346
--- /dev/null
+++ b/debian/patches/cherry-picked/g10-Fix-garbled-status-messages-in-NOTATION_DATA.patch
@@ -0,0 +1,47 @@
+From: Werner Koch <wk@gnupg.org>
+Date: Tue, 14 Jun 2022 11:33:27 +0200
+Subject: g10: Fix garbled status messages in NOTATION_DATA
+
+* g10/cpr.c (write_status_text_and_buffer): Fix off-by-one
+--
+
+Depending on the escaping and line wrapping the computed remaining
+buffer length could be wrong. Fixed by always using a break to
+terminate the escape detection loop. Might have happened for all
+status lines which may wrap.
+
+GnuPG-bug-id: T6027
+(cherry picked from commit 34c649b3601383cd11dbc76221747ec16fd68e1b)
+---
+ g10/cpr.c | 13 ++++---------
+ 1 file changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/g10/cpr.c b/g10/cpr.c
+index d502e8b..bc4b715 100644
+--- a/g10/cpr.c
++++ b/g10/cpr.c
+@@ -328,20 +328,15 @@ write_status_text_and_buffer (int no, const char *string,
+ }
+ first = 0;
+ }
+- for (esc=0, s=buffer, n=len; n && !esc; s++, n--)
++ for (esc=0, s=buffer, n=len; n; s++, n--)
+ {
+ if (*s == '%' || *(const byte*)s <= lower_limit
+ || *(const byte*)s == 127 )
+ esc = 1;
+ if (wrap && ++count > wrap)
+- {
+- dowrap=1;
+- break;
+- }
+- }
+- if (esc)
+- {
+- s--; n++;
++ dowrap=1;
++ if (esc || dowrap)
++ break;
+ }
+ if (s != buffer)
+ es_fwrite (buffer, s-buffer, 1, statusfp);
diff --git a/debian/patches/series b/debian/patches/series
index 246c0e1..c3998eb 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -21,6 +21,7 @@ Make-gpg-zip-use-tar-from-PATH.patch
gpg-drop-import-clean-from-default-keyserver-import-optio.patch
from-master/gpg-change-agent-spawn-2019-07-24-v2.patch
cherry-picked/1617856888.gnupg-2.3.0-4-gab66c4357.scd-fix-ccid-driver-for-scm-spr332-spr532.patch
+cherry-picked/g10-Fix-garbled-status-messages-in-NOTATION_DATA.patch
progress-linux/0001-gpgsm-default-to-4096-bit-keys.patch
progress-linux/0002-gpg-default-to-4096-bit-keys.patch
progress-linux/0003-gpg-default-key-to-ed25519.patch