summaryrefslogtreecommitdiffstats
path: root/share/keys/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:29:01 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:29:01 +0000
commit35a96bde514a8897f6f0fcc41c5833bf63df2e2a (patch)
tree657d15a03cc46bd099fc2c6546a7a4ad43815d9f /share/keys/CMakeLists.txt
parentInitial commit. (diff)
downloadinkscape-35a96bde514a8897f6f0fcc41c5833bf63df2e2a.tar.xz
inkscape-35a96bde514a8897f6f0fcc41c5833bf63df2e2a.zip
Adding upstream version 1.0.2.upstream/1.0.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'share/keys/CMakeLists.txt')
-rw-r--r--share/keys/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/share/keys/CMakeLists.txt b/share/keys/CMakeLists.txt
new file mode 100644
index 0000000..0d770cd
--- /dev/null
+++ b/share/keys/CMakeLists.txt
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+file(GLOB _FILES "*.xml")
+install(FILES ${_FILES} DESTINATION ${INKSCAPE_SHARE_INSTALL}/keys)
+
+# install a duplicate of inkscape.xml as default.xml
+# default.xml is the default keymap that will be used by inkscape after installation
+# replace this with a keymap of your own to override the Inkscape default shortcuts
+install(FILES inkscape.xml
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/keys
+ RENAME default.xml)