summaryrefslogtreecommitdiffstats
path: root/modules/ta_update/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 10:41:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 10:41:58 +0000
commit1852910ef0fd7393da62b88aee66ee092208748e (patch)
treead3b659dbbe622b58a5bda4fe0b5e1d80eee9277 /modules/ta_update/meson.build
parentInitial commit. (diff)
downloadknot-resolver-1852910ef0fd7393da62b88aee66ee092208748e.tar.xz
knot-resolver-1852910ef0fd7393da62b88aee66ee092208748e.zip
Adding upstream version 5.3.1.upstream/5.3.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'modules/ta_update/meson.build')
-rw-r--r--modules/ta_update/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/ta_update/meson.build b/modules/ta_update/meson.build
new file mode 100644
index 0000000..f295cba
--- /dev/null
+++ b/modules/ta_update/meson.build
@@ -0,0 +1,19 @@
+# LUA module: ta_update
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+config_tests += [
+ ['ta_update', files('ta_update.test.lua'), ['snowflake']],
+]
+
+integr_tests += [
+ ['ta_update', meson.current_source_dir() / 'ta_update.test.integr'],
+ ['ta_update.unmanagedkey', meson.current_source_dir() / 'ta_update.unmanagedkey.test.integr'],
+]
+
+lua_mod_src += [
+ files('ta_update.lua'),
+]
+
+install_data(
+ install_dir: modules_dir / 'ta_update',
+)