summaryrefslogtreecommitdiffstats
path: root/RepositoryModule_host.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /RepositoryModule_host.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream/1%7.0.4.tar.xz
libreoffice-upstream/1%7.0.4.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'RepositoryModule_host.mk')
-rw-r--r--RepositoryModule_host.mk198
1 files changed, 198 insertions, 0 deletions
diff --git a/RepositoryModule_host.mk b/RepositoryModule_host.mk
new file mode 100644
index 000000000..3155224ff
--- /dev/null
+++ b/RepositoryModule_host.mk
@@ -0,0 +1,198 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+
+$(eval $(call gb_Module_Module,libreoffice))
+
+# This makefile needs to be read first because some variables like T_LIBS
+# for libmerged are cleared there and then later we append stuff to it
+# through e.g. gb_Library_use_external for various libraries in libmerged.
+ifneq ($(MERGELIBS),)
+$(eval $(call gb_Module_add_targets,libreoffice,\
+ Library_merged \
+))
+endif
+
+$(eval $(call gb_Module_add_moduledirs,libreoffice,\
+ accessibility \
+ android \
+ animations \
+ apple_remote \
+ $(call gb_Helper_optional,AVMEDIA,avmedia) \
+ basctl \
+ basegfx \
+ basic \
+ bean \
+ binaryurp \
+ bridges \
+ canvas \
+ chart2 \
+ cli_ure \
+ $(call gb_Helper_optional,DESKTOP,codemaker) \
+ comphelper \
+ configmgr \
+ connectivity \
+ cppcanvas \
+ cppu \
+ cppuhelper \
+ cpputools \
+ cui \
+ dbaccess \
+ desktop \
+ $(call gb_Helper_optional,DICTIONARIES,dictionaries) \
+ dtrans \
+ drawinglayer \
+ editeng \
+ embeddedobj \
+ embedserv \
+ eventattacher \
+ extensions \
+ external \
+ extras \
+ filter \
+ $(call gb_Helper_optional,DBCONNECTIVITY,forms) \
+ formula \
+ $(call gb_Helper_optional,DESKTOP,fpicker) \
+ framework \
+ $(call gb_Helper_optional,DESKTOP,helpcompiler) \
+ $(call gb_Helper_optional,HELP,helpcontent2) \
+ hwpfilter \
+ i18nlangtag \
+ i18npool \
+ i18nutil \
+ idl \
+ $(call gb_Helper_optional,DESKTOP,idlc) \
+ instsetoo_native \
+ io \
+ javaunohelper \
+ jurt \
+ jvmaccess \
+ jvmfwk \
+ librelogo \
+ libreofficekit \
+ lingucomponent \
+ linguistic \
+ lotuswordpro \
+ $(call gb_Helper_optional,DESKTOP,l10ntools) \
+ $(call gb_Helper_optional,NLPSOLVER,nlpsolver) \
+ o3tl \
+ $(call gb_Helper_optional,ODK,odk) \
+ offapi \
+ officecfg \
+ onlineupdate \
+ oovbaapi \
+ oox \
+ $(call gb_Helper_optional,OPENCL,opencl) \
+ package \
+ pch \
+ postprocess \
+ $(call gb_Helper_optional,PYUNO,pyuno) \
+ $(call gb_Helper_optional,QADEVOOO,qadevOOo) \
+ readlicense_oo \
+ registry \
+ remotebridges \
+ reportbuilder \
+ $(call gb_Helper_optional,DBCONNECTIVITY,reportdesign) \
+ ridljar \
+ sal \
+ salhelper \
+ sax \
+ sc \
+ scaddins \
+ sccomp \
+ $(call gb_Helper_optional,DESKTOP,scp2) \
+ scripting \
+ sd \
+ sdext \
+ $(call gb_Helper_optional,DESKTOP,setup_native) \
+ sfx2 \
+ shell \
+ slideshow \
+ smoketest \
+ solenv \
+ soltools \
+ sot \
+ starmath \
+ stoc \
+ store \
+ svl \
+ svtools \
+ svgio \
+ emfio \
+ svx \
+ sw \
+ swext \
+ sysui \
+ test \
+ testtools \
+ toolkit \
+ tools \
+ ucb \
+ ucbhelper \
+ udkapi \
+ $(call gb_Helper_optional,PYUNO,uitest) \
+ UnoControls \
+ unodevtools \
+ unoil \
+ unoidl \
+ unotest \
+ unotools \
+ unoxml \
+ ure \
+ uui \
+ vbahelper \
+ vcl \
+ winaccessibility \
+ wizards \
+ writerfilter \
+ writerperfect \
+ xmerge \
+ $(call gb_Helper_optional,DESKTOP,xmlhelp) \
+ xmloff \
+ xmlreader \
+ xmlscript \
+ xmlsecurity \
+))
+
+# Especially when building everything with symbols, the linking of the largest
+# libraries takes enormous amounts of RAM. To prevent annoying OOM situations
+# etc., try to prevent linking these in parallel by adding artificial build
+# order dependencies here.
+define repositorymodule_serialize1
+$(call gb_LinkTarget_get_target,$(call gb_Library_get_linktarget,$(1))) \
+ :| $(foreach lib,$(2),$(call gb_Library_get_target,$(lib)))
+endef
+
+define repositorymodule_serialize
+$(if $(filter-out 0 1,$(words $(1))),\
+$(call repositorymodule_serialize1,$(firstword $(1)),$(wordlist 2,$(words $(1)),$(1))))
+$(if $(strip $(1)),\
+$(call repositorymodule_serialize,$(wordlist 2,$(words $(1)),$(1))))
+endef
+
+# DO NOT SORT ALPHABETICALLY: the libraries must be listed in dependency order,
+# otherwise cyclic dependencies ruin everything.
+# do not serialize on a partial build as that may fail due to missing deps.
+# the default goal is build (see Module.mk)
+ifeq (,$(filter-out build check unitcheck slowcheck screenshot subsequentcheck uicheck,$(MAKECMDGOALS)))
+$(eval $(call repositorymodule_serialize,\
+ scfilt \
+ $(call gb_Helper_optional,SCRIPTING,vbaobj) \
+ sc msword \
+ $(call gb_Helper_optional,DESKTOP,swui) \
+ sw sd \
+ $(call gb_Helper_optional,DBCONNECTIVITY,dbu) \
+ writerfilter cui chartcontroller chartcore oox \
+ $(if $(MERGELIBS), merged, \
+ svx svxcore xo sfx fwk svt vcl) \
+))
+endif
+
+# vim: set noet sw=4 ts=4: