summaryrefslogtreecommitdiffstats
path: root/avmedia/Library_avmediavlc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /avmedia/Library_avmediavlc.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'avmedia/Library_avmediavlc.mk')
-rw-r--r--avmedia/Library_avmediavlc.mk56
1 files changed, 56 insertions, 0 deletions
diff --git a/avmedia/Library_avmediavlc.mk b/avmedia/Library_avmediavlc.mk
new file mode 100644
index 000000000..3db43315e
--- /dev/null
+++ b/avmedia/Library_avmediavlc.mk
@@ -0,0 +1,56 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,avmediavlc))
+
+$(eval $(call gb_Library_set_componentfile,avmediavlc,avmedia/source/vlc/avmediavlc))
+
+$(eval $(call gb_Library_set_include,avmediavlc,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/avmedia/source/inc \
+ -I$(SRCDIR)/avmedia/source/vlc/inc \
+))
+
+$(eval $(call gb_Library_use_custom_headers,avmediavlc,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_use_sdk_api,avmediavlc))
+
+$(eval $(call gb_Library_use_externals,avmediavlc,\
+ boost_headers \
+ boost_system \
+))
+
+$(eval $(call gb_Library_use_libraries,avmediavlc,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ vcl \
+ utl \
+ salhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,avmediavlc,\
+ avmedia/source/vlc/vlcmanager \
+ avmedia/source/vlc/vlcplayer \
+ avmedia/source/vlc/vlcuno \
+ avmedia/source/vlc/vlcwindow \
+ avmedia/source/vlc/vlcframegrabber \
+ avmedia/source/vlc/wrapper/Instance \
+ avmedia/source/vlc/wrapper/Media \
+ avmedia/source/vlc/wrapper/Player \
+ avmedia/source/vlc/wrapper/EventManager \
+ avmedia/source/vlc/wrapper/EventHandler \
+ avmedia/source/vlc/wrapper/Common \
+))
+
+# vim: set noet sw=4 ts=4: