summaryrefslogtreecommitdiffstats
path: root/bean/Module_bean.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /bean/Module_bean.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bean/Module_bean.mk')
-rw-r--r--bean/Module_bean.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/bean/Module_bean.mk b/bean/Module_bean.mk
new file mode 100644
index 000000000..08d939076
--- /dev/null
+++ b/bean/Module_bean.mk
@@ -0,0 +1,29 @@
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Module_Module,bean))
+
+ifneq ($(ENABLE_JAVA),)
+
+ifneq ($(OS),MACOSX)
+ifneq ($(OS),ANDROID)
+$(eval $(call gb_Module_add_targets,bean,\
+ Jar_officebean \
+ Library_officebean \
+))
+
+# complex tests compilable but fail at runtime
+#$(eval $(call gb_Module_add_subsequentcheck_targets,bean,\
+# JunitTest_bean_complex \
+#))
+endif
+endif
+
+endif